Jump to content
Cameron

TBM 900 v1.0.9 Update Released!

Recommended Posts

Hello All,

This will serve as a formal forum announcement that we have released the version 1.0.9 update for the TBM 900. All customers who have purchased the TBM 900 up till now have been sent an e-mail by X-Aviation with complete instructions on how to obtain your update. We have made this a very simple process! For those that purchase the TBM 900 from today forward, your purchased download will already be updated to version 1.0.9 for you.

What if I didn't get the update e-mail?

If you did not receive your update e-mail don't fret! X-Aviation has updated our system to allow all customers to update with ease, regardless of whether you received an e-mail for the update! Here's what to do:

1. Login to your X-Aviation account here: https://www.x-aviation.com/catalog/account_history.php

2. Find your original TBM 900 download and re-download the file. It will download as the latest version!

The following is a list of additions/fixes included:
 
What's New / Changed:

  • Minor mesh fixes on front fuselage to patch up model holes
  • Fixed high levels of gloss on ailerons
  • Fixed texture artefacts on deice panel screws
  • Artificial horizon light scatter fixed
  • New datarefs on spill lights for glareshield
  • Automatic switching from GPS to LOC guidance on a programmed approach wasn't engaging LOC mode properly
  • Weight-on-wheels sensors should be on all gear legs
  • OFV should begin modulating on the takeoff roll
  • Switched state timer from microclock to unixtime due to potential problem with microsecond rollover on Windows
  • vrconfig with hotspots for walkaround
  • Fixed sudden pitch change when AP was engaged with the aircraft out of trim
  • Retuned steering constants to make crosswind takeoffs easier
  • Lowered minimum PAX weight to allow for children
  • Lightened overhead panel textures to look better
  • Implemented aircraft reset to Cold & Dark when selecting 'No' in flight recovery or when a new airframe is created
  • Increased cloud cover sun radiation decrease factor to not overheat the cabin so easily on cold weather
  • Increased cabin surface heat flow rate to cool the cabin a bit in colder weather
  • Implemented hard crash detection
  • Refactored panel overlay drawing code to avoid hard-coding panel viewport offsets to help with rendering on multi-monitor setups
  • Made negative-G effect of fuel instability less pronounced
  • FMS keyboard box joystick move UP should tilt radar down on radar page
  • Fuel indicator should display proper inop indication instead of amber XXX
  • Added code to detect left-most monitor and display drawer there
  • Fixed UI scaling support issues - all windows should now rescale & behave properly with UI size > 100%
  • Fixed windows not properly centering on multi-monitor setups
  • Smartcopilot compatibility fixes - very early work
  • Pushing CWS shouldn't emit the AP disconnection sound
  • Flipped default CB light position to be off
  • Very short runways could cause a div-by-zero in the runway segment number determination
  • Added xEnviro integration to read rain rate.
  • High-elevation VORs and ILSes could sometimes fail being received due to signal propagation computation errors

As always, thanks for being a customer with X-Aviation. We appreciate your feedback and support!


Enjoy these latest updates, and stay tuned to the forum as we continually announce the latest happenings.

  • Like 4

Share this post


Link to post
Share on other sites

Hi,

this is because nearly everything is defect (check maintenance). Best is to create a new airframe.

I didn´t figure out if it is due to the update or the new "cold & dark" feature after a CTD.

Share this post


Link to post
Share on other sites

Heeii guys,

Thanks for the Update :). But can someone tell me why the MFD Display shows the PFD Display? How can I fix that or is that a bug? That happend since I installed the Update. Than you so much for the answers.

2018-11-03 13_20_11-X-System.jpg

Share this post


Link to post
Share on other sites
9 minutes ago, daniellux4991 said:

Heeii guys,

Thanks for the Update :). But can someone tell me why the MFD Display shows the PFD Display? How can I fix that or is that a bug? That happend since I installed the Update. Than you so much for the answers.

2018-11-03 13_20_11-X-System.jpg

press the red button in the PFD

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Guys thanks for update

1. Scaling issue partially solved. Messages are not visible with scaling 150%. Oxygen mask also has some kind of artifact

2. No sure why I had engine failed in flight (could be pilot error). With engine completely shut down I got a lot of airspeed almost like invisible power was still on . I also had problem decelerating or bleeding airspeed while in power off glide!

 

Still love TBM, did emergency landing AOK :)

Log.txt

Share this post


Link to post
Share on other sites

CTD again and again ! these crashes happen randomly :

-CTD when I put full fuel tank but when I reload plane tanks are still full and no more crash

-CTD when I put ON crash bar

-CTD when I enter a procedure with some airport (eg: CYYR ILS Y 08) press LOAD and crash

-CTD during cruise

-CTD during approach

 

log:

2018-11-03 19:41:05 TBM900[except.c:171]: Caught EXCEPTION_ACCESS_VIOLATION

 

max flight time is approx 1 hour for me, after this time it crash for some reason. it crash so much it become annoying...

I dont want to be harsh, every addons has bug, I know, but not so much CTD.

  • Upvote 1

Share this post


Link to post
Share on other sites

Per Nikit's issue. I had the same thing. After allot of experimentation, I found that my x-plane installation had corrupted. After performing some testing flights today, I too was getting CTD for the first time. I totally re-installed X-plane and this add on only. I have a really good rig and get very good frame rates. I also have 32 GB of memory. What I found was a shocking. A memory leak with this aircraft running my computer out of memory after a certain length of time. This is just very sad to see. The version before this one had no such issue. I'll go back to my 727 V2 for a while until they get this all straightened out. 

Share this post


Link to post
Share on other sites

Update . I started again. Deleted all airframes, created new ones. Repeated my route , and so far (knock knock knock) no issue .

I’m currently on the long haul for 4 hours straight stress test


Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×