Sign in to follow this  
Followers 0
mutt90

X-aviation licensing window

14 posts in this topic

Today, i purchased Skymaxx pro and real weather.

Now, when i start XP, I get  a pop up X-aviation Licensing windows listing my email, all my products( 6 x-aviation products) and at the top says Next License check: 14 days, 4:49:22 and it counts down. i can close it, but it pops back up immediately. Very annoying.

Also,I installed skymaxx and real weather. I get the drop down in plugins for skymaxx, but nothing for real weather. I assume this is because of this licensing issue.

 

Any ideas?

 

Thanks

 

0

Share this post


Link to post
Share on other sites
5 hours ago, mutt90 said:

Today, i purchased Skymaxx pro and real weather.

Now, when i start XP, I get  a pop up X-aviation Licensing windows listing my email, all my products( 6 x-aviation products) and at the top says Next License check: 14 days, 4:49:22 and it counts down. i can close it, but it pops back up immediately. Very annoying.

Also,I installed skymaxx and real weather. I get the drop down in plugins for skymaxx, but nothing for real weather. I assume this is because of this licensing issue.

 

Any ideas?

 

Thanks

 

Please post your Log.txt and GizmoLog.txt files.

0

Share this post


Link to post
Share on other sites
Please post your Log.txt and GizmoLog.txt files.

Thanks. I will when I get home from work

Sent from my Pixel 2 XL using Tapatalk

0

Share this post


Link to post
Share on other sites
Attached are the logs

GizmoLog.txt

Log.txt

In the window that pops up you should see a button that says "update". Clicking this should refresh your license for the two new purchases.

0

Share this post


Link to post
Share on other sites

The box that popped up did not have an update button. I did notice this in other similar forum posts i've seen elsewhere where there was screenshot showing that button.

That being said, i just clicked all over  the box and then it did update. So, the bottom line is it looks like its resolved.

Thanks everyone for your help

 

 

0

Share this post


Link to post
Share on other sites
1 hour ago, maor grinberg said:

i still dont have this resolved.

I cannot reproduce this bug on my 970m.

I'm still searching for the pattern of what causes it. It seems to be related to 1070 and 1080 cards but some users do not see a problem.

 

I've made contact with Laminar today to see if we can gain any insight into what might be happening but without a consistent set of data as to what causes it I can't give them much solid direction either.

 

For now, use a non beta install of the sim.

The VR beta branch is undergoing many changes under the hood to optimize the XP rendering engine.

 

I'm as annoyed as you are.

0

Share this post


Link to post
Share on other sites

I've been able to reproduce this bug on my local machine by forcing X-Plane to use my Intel GPU.

I should be able to make some progress resolving this now.

 

0

Share this post


Link to post
Share on other sites

I seem to have located the root cause of this problem.

At this time I believe it's on Laminars end as it's calls to the SDK function XPLMDrawString(...) that are creating the problem.

 

We're working with Laminar to resolve the issue and hopefully we'll see a fix shipped in 11.20r2.

1

Share this post


Link to post
Share on other sites

I spent the day writing a clean-sheet plugin in C to Proof-of-Concept this so Laminar can trouble shoot as efficiently as possible.

I have been able to reproduce the issue.

 

At this stage it looks like the error is not actually in XPLMDrawString(...) but some other OpenGL related code.

Probably best if I do not continue to speculate. The exact root cause will reveal itself soon enough.

0

Share this post


Link to post
Share on other sites

FWIW I'm running XP 11.20p1 on Mac and the Aviation licensing window pops up all the time but the actual email and password fields are not there so I cannot enter my information. I tried reinstalling SkyMaxx Pro 4.6 but that didn't help.

0

Share this post


Link to post
Share on other sites
FWIW I'm running XP 11.20p1 on Mac and the Aviation licensing window pops up all the time but the actual email and password fields are not there so I cannot enter my information. I tried reinstalling SkyMaxx Pro 4.6 but that didn't help.

This is the same issue as outlined above. Laminar should hopefully have a fix in the next update for X-Plane.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.