Jump to content
Schorle

Unable to activate

Recommended Posts

5 minutes ago, Schorle said:

Same result. Not working.

Please confirm that it works normally in 11.10?

This bug appears to be something that Laminar have changed in the 11.20 run. There is little I can do.

They're also puzzled by the error symptoms on your machine at this point.

Edited by Ben Russell
typo

Share this post


Link to post
Share on other sites

Can you do a clean install, either in a separate folder or a separate partition.  No plug ins.  Everything just vanilla X Plane, and just install the Saab.  So ONLY X-Plane and Saab installed.

 

Share this post


Link to post
Share on other sites
18 minutes ago, Goran_M said:

Can you do a clean install, either in a separate folder or a separate partition.  No plug ins.  Everything just vanilla X Plane, and just install the Saab.  So ONLY X-Plane and Saab installed.

 

Schorle has already tried this and more. :mellow:

- Bare demo with Gizmo. Fails as above.

- Bare demo with test plugin. Fails in a dramatic way: All button widgets fail to draw.

 

At the moment all we can do is wait for Lamianr.

The team member I've been talking to about it has the same CPU and same GPU but does NOT see the bug.

They were able to use the test plugin during the RC2 -> RC3 revision to partially fix the error resulting in me no longer having any local problems.

 

It's a very very strange issue. I've asked Cameron to notify Austin directly about it so that they do not go 11.20 final release without fixing it.

If they do I will not be amused.

 

Schorle: If you would like to do more testing you could download some of the various free plugins available for X-Plane and see if they also fail to draw widgets.

For example: Dataref Tool

https://github.com/leecbaker/datareftool/releases

 

The test plugin I wrote for Laminar uses a fairly specific set of code instructions to trigger the glitch.

If you can find other widely used and available plugins that are also glitching it may help resolve the issue.

Share this post


Link to post
Share on other sites

Tried the Dataref Tools plugin and this one is also giving weird results: Screen goes into very low res and is starting to flicker like crazy. When removing the plugin everything is fine again.

  • Upvote 1

Share this post


Link to post
Share on other sites
On 5/6/2018 at 3:21 AM, Schorle said:

Tried the Dataref Tools plugin and this one is also giving weird results: Screen goes into very low res and is starting to flicker like crazy. When removing the plugin everything is fine again.

Hi there,

Do you have the X-Plane UI setting at a larger size? Something above 100% may cause this issue from what we're discovering with Laminar.

If you have a X-Plane UI setting higher than 100%, please set it back to 100% and report back here.

  • Upvote 1

Share this post


Link to post
Share on other sites

Cameron, you are completely right! That did the trick!

After setting back UI to 100% it is working perfectly. Strange though, that everything is fine on 11.11 using scaled (150%) UI.

Nevertheless, thanks a lot!

Share this post


Link to post
Share on other sites
24 minutes ago, Schorle said:

Cameron, you are completely right! That did the trick!

After setting back UI to 100% it is working perfectly. Strange though, that everything is fine on 11.11 using scaled (150%) UI.

Nevertheless, thanks a lot!

The rendering engine would have some fairly aggressive changes and revisions in it to optimize for VR, every fraction of a frame counts.

Glad to hear we finally got to the bottom of this very strange glitch. Hopefully it resolves the issue for others seeing the same thing.

 

Share this post


Link to post
Share on other sites
The rendering engine would have some fairly aggressive changes and revisions in it to optimize for VR, every fraction of a frame counts.

Glad to hear we finally got to the bottom of this very strange glitch. Hopefully it resolves the issue for others seeing the same thing.

 

Glad it helped. Laminar now has this bug patched for an upcoming 11.21 release.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×