Jump to content
Captsalt

TerraMaxx fails to operate

Recommended Posts

I have tried several times but TerraMaxx fails to function (ZERO) changes in default scenery. I've attached the error that comes up as well as the LOG file from X-Plane 11 folder.

You'll notice within the file (scroll down) that indicates "Incorrect version for scenery library file. Will skip". SEE BELOW.

0:00:00.033 D/HID: HID Bridge Running
0:00:30.099 E/SYS: +-------------------------------------------------------------------------------
0:00:30.099 E/SYS: | There was a problem loading the scenery package:
0:00:30.099 E/SYS: | Custom Scenery/SeasonsXP/
0:00:30.099 E/SYS: | The scenery may not look correct.
0:00:30.099 E/SYS: | Please see the log.txt file for detailed error information.
0:00:30.099 E/SYS: | (io_locate.cpp:394)
0:00:30.099 E/SYS: +-------------------------------------------------------------------------------
0:00:30.099 E/SCN: Custom Scenery/SeasonsXP/library.txt:
0:00:30.099 E/SCN: Incorrect version for scenery library file.  Will skip.
ATC audio initialized.

Can anyone help?

Thanks,

Captsalt

X-Plane 11 after TerraMaxx install.PNG

 

Log.txt

Edited by Captsalt
Wrong file attached

Share this post


Link to post
Share on other sites
4 hours ago, Captsalt said:

0:00:30.099 E/SCN: Incorrect version for scenery library file.  Will skip.

Seems as if something went wrong with your installation. Did you do anything to the SeasonsXP/library.txt file? Try uninstalling and reinstalling TerraMaxx and before modifying any files make a backup copy of the SeasonsXP folder. 

The log.txt states your are using XP 11.11r2? As far as I know TerraMaxx needs the 11.20 beta version to run. 

 

Edited by paradoxagi

Share this post


Link to post
Share on other sites

It will run in 11.11 but aircraft liveries will change when seasons do, yes it seems like something went wonkey with your path or maybe permissions are needed for your xp folder? If try a reinstall and see...

Share this post


Link to post
Share on other sites

I updated to 11.20 beta and the program loaded but I received the file version error after the aircraft loaded this time. I uninstalled TerraMaxx and am reinstalling now (long d/l time, apparently a slow server). Will let the group know how it turns out. BTW, THANK YOU for responding guys! I couldn't/can't get X-Aviation to respond ... or, are you them? :)

Captsalt 

Share this post


Link to post
Share on other sites
9 hours ago, Captsalt said:

I couldn't/can't get X-Aviation to respond ... or, are you them?

I am not a member of X-Aviation, but John is. I just kown a bit about how TerraMaxx works because I got into it for creating seasonal sceneries. And I know the library.txt error because I created this error myself already with one of my own libraries - so I thought I could myabe solve your problem. 

:-)

 

 

Share this post


Link to post
Share on other sites

Good morning, Well, this whole process is more than a little frustrating. After waiting for over three hours for the D/L process of component one, it failed to go to the next componet and restarted the D/L. When I cancelled the, I lost the entire D/L. Where are the files stored and can I resume the D/L?

They REALLY need to have a CD/DVD available!

HELP! Thanks again.

Edited by Captsalt
Spelling error

Share this post


Link to post
Share on other sites

Yes... slow internet connections are really frustrating when it comes to large downloads like this one. But this maybe could be a reason why your library file seems to be corrupted - and this is good news because the problem is fixable easily then. 

I think you have to be patient and finish the download process completely. Then, once it's done, make a backup copy of the seasonsxp folder, just for sure. 

I have no idea where the downloader stores temporary files - the final installation gives you the SeasonsXP folder with the seasonal content and the TerraMaxx plugin inside the X-Plane plugins folder. 

Share this post


Link to post
Share on other sites

That's a good question. This should happen without you doing anything. So, either your connection is slow or the download servers are very busy at this time. If I had this problem, I would try the following:

1. restart the internet router 

2. restart the pc 

and then wait some minutes until your internet is back up again and try again. This will very like solve a problem at your end, if one existst. If the download servers are the culprit here, you have to wait for them to recover. 

Edited by paradoxagi

Share this post


Link to post
Share on other sites

Thanks for the response, I'm D/L the file AGAIN and will let it wait. However, the last time I did that, the file initiated a new D/L and I was back to ground zero.

My internet connection is "reasonable" with a current D/L speed showing as 1105 KB/s.

Share this post


Link to post
Share on other sites

Just to make sure we're barking up the right tree, it might be a good idea to open up your Custom Scenery/SeasonsXP/library.txt file and see if it is in fact corrupt.

It should start with:

A
800
LIBRARY

If it doesn't, then that supports the corrupt download theory and would explain the error you're seeing.

 

Share this post


Link to post
Share on other sites

I did make a back folder of the one that failed. Interestingly enough, the only thing in the file is: #library/SeasonsXP/textures/24831

I'm waiting for the D/L to (hopefully) finish and will try a fresh install.

Thanks again for the help!

 

Share this post


Link to post
Share on other sites

The D/L stopped as before. See Attached picture showing the stop point. 

After waiting, the D/L process restarted again at the beginning! How do I get it to continue?

Can you direct me to the temp location where the files are stored and, if so, is the a refresh or continue download function?

Please assist. Thanks.

TerraMaxx DL stop point.PNG

Share this post


Link to post
Share on other sites

The downloaded files are not in a format that you can self de-compress, and if the installer fails to move from one component to the next that's because your internet has not downloaded the full data available to close the loop on the first component.

Re-downloading after a successful install was likely not a wise move here. The installers will FAIL to install any kind of files at all if there is any corruption in the downloaded files. There are checksum processes along the way to avoid corruption. The files are all hosted on Amazon servers, so to assume they are "slow" would be false. Any kind of speed issues are going to be coming from your end, or something to do with your ISP network in the moment.

Unfortunately there's nothing we can do on our end in a scenario like this, and I have not had a single customer contact me about a situation like this (I can only assume their internet gave no issues). I assume this is on a desktop? Do you have a laptop handy at all?

Share this post


Link to post
Share on other sites

This is a desktop and no to the Laptop. My download speeds are approximately 1000 kb/s (which should be sufficient).

So ... how do I get a "clean install"? I did an uninstall prior to the last download. I did make a backup of the SeasonXP folder.

How do I proceed?

 

Share this post


Link to post
Share on other sites
This is a desktop and no to the Laptop. My download speeds are approximately 1000 kb/s (which should be sufficient).

So ... how do I get a "clean install"? I did an uninstall prior to the last download. I did make a backup of the SeasonXP folder.

How do I proceed?

 

You made a backup of the seasons xp folder? We might be able to work with that. Can you tell me the size of the folder, please?

Share this post


Link to post
Share on other sites

Now THAT is odd. The installed folder size should be anywhere 10-12 GB. The installer will not de-compress something less than a full file, so that begs the question of why you have such an incomplete folder (and would answer why you don't have textures loading in certain situations).

Can you confirm that your hard drive where you keep X-Plane installed has the proper space available for a full install?

Share this post


Link to post
Share on other sites

I have the X-Plane 11 Folder installed on my desktop.

My C: drive has 665 GB free of 931 GB drive.The D: Drive has 514 GB free.

Where to now?

Thanks for the continued help.

Edited by Captsalt

Share this post


Link to post
Share on other sites

Did you have an install going and then choose to skip a component or something the first time you had a successful install? Can you share a screenshot of that folder you have backed up?

Share this post


Link to post
Share on other sites

I've attached a screen shot of the SeasonsXp backup folder contents. As indicated before, the contents has 14,902 files, 9 folders with a total size of 1.15 GB (1,238,392,832 bytes). Lewt me know if you need any other detail, Another question: Does the default X-Plane 11 have the SeasonsXP folder in some form? Even though TerraMaxx isn't currently installed, I get a notice every time I load an aircraft up in X-Pnae 11 that the scenery has loaded properly.

Thanks,

Don

SeasonsXP Folder Contents.PNG

Edited by Captsalt

Share this post


Link to post
Share on other sites

X-Plane 11 does not come with a SeasonsXP folder by default. 

As long as your SeasonsXP folder (or the backup) is in Custom Scenery and is not set to SCENERY_PACK_DISABLED in the Scenery-Packs.ini, XP will try to load it's content. And this leads to the error message because your library.txt is corrupted. So, if you want to disable the errror massage, you have to move the SeasonsXP and the backup to another location. 

Could you complete the installer and download successfully?

Share this post


Link to post
Share on other sites

No, the download process hangs at what appears to be after the 1st component. At this point, I want to get my X-Plane 11 back to where it was before this nightmare started. I don't know if my situation is unique or not. I'd sure like to get TerraMaxx working as it's a great concept but maybe not ready for "prime time". Like I said, maybe my situation is unique but I doubt it.

 

Share this post


Link to post
Share on other sites

If you want to go back to a default situation, move the SeasonsXP and the backup so it's not in Custom Scenery and do the same with the plugin (it's in X-Plane 11/Resources/Plugins). 

Do you have a second computer ready? Maybe you can do the download there and then move the plugins (TerraMaxx and Gizmo) and the SeasonsXP folder from the hopefully completed download to your X-Plane computer. I think there is something messed up in your machine or some problem with temp files so it can't complete this task. Did you disable your antivirus when trying to install TerraMaxx? 

Edited by FlyAgi

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×