Jump to content
Sign in to follow this  
d0rkiishchris

[Confirmed]FMS crash

Recommended Posts

I'll have to change a runway due to wind.  Or add a transition to a STAR.  Today I've confirmed it.  Flying into KATL from KTPA.  I went to change to a runway closer to the terminal and bam, console crash.  I've had the plane for 3 days and I'm really not happy, sorry.  

Here is an image of what happens.  And the FMS basically becomes unuseable.   

 

I'm not sure what files you need, debug 1 and 2 don't seem to be the flight I was on.  But the FMS debug and the screen shot show it.  Also if you look at the FMS for KATL, it says there are 7 pages.  None of which I can access.  What if I needed to reroute?

ixeg fms runway change.jpg

IXEG_debug_01.txt

IXEG_debug_02.txt

IXEG_FMS_debug.txt

console crash.jpg

Edited by Morten

Share this post


Link to post
Share on other sites

Yeah, its still a major nuisance and I am sorry that you experience these crashes. I am not quite sure why you get hit so hard, for the most part these crashes have dwindled down to almost zero, it seems.

I will try to recreate the crash you reported and then we can fix it for the next update. In the meantime you may be able to avoid this issue by going a slightly different way about entering the alteration, maybe changing the runway first, then the STAR/transition or the other way around.

If there is a way you can determine which exact sequence causes the crash, that would be helpful, too.

Since it seems to happen to you basically on every flight, maybe you can catch the occurance (with the keys you are pressing) on a short video, these are usually priceless in hunting the problem down.

Are you using Navigraph or Aerosoft nav-data?

Sorry for the trouble, Jan

 

Share this post


Link to post
Share on other sites

I've switched it up.  But I'm on an approach now with VNAV running, I'll see if I can make it hiccup.   I'll record with OBS.  I'm sure I can get it to happen.  Who knows though,. take your car to the shop to replicate a problem and then it goes away.  lol

  • Upvote 1

Share this post


Link to post
Share on other sites

The latest version is 1.21 - you should see that on the FMS INIT REF page in the plane.

The latest version of X-Plane is 11.10 - but running on a VR alpha or soon 11.20 beta version should not affect the FMS calculation.

If you just recently (after February, 8th) purchased the plane, you should be running the latest version.

And roger on the video, looking forward to seeing it and getting the bug stomped.

Cheers, Jan

 

Share this post


Link to post
Share on other sites

This video shows another issue.  If I fly from one place to another like I did.  And don't reset the plane.  Just setup a new flight plan.  When engaging VNAV it will not obey 250 knots below 10,000 feet.  And goes straight for the mach .72 climb, which is like 400 knots at 11,000 feet.  It won't climb either.  

Share this post


Link to post
Share on other sites
1 hour ago, Litjan said:

The latest version is 1.21 - you should see that on the FMS INIT REF page in the plane.

The latest version of X-Plane is 11.10 - but running on a VR alpha or soon 11.20 beta version should not affect the FMS calculation.

If you just recently (after February, 8th) purchased the plane, you should be running the latest version.

And roger on the video, looking forward to seeing it and getting the bug stomped.

Cheers, Jan

 

I've tried to make a video where it crashes, just flew back to tampa.  I changed the approach, star, you name it probably ten times each.  I wasn't using VNAV.  The problem never occurred.  Is this crash stemmed from VNAV?  If it is, I just won't use it on descent.

Share this post


Link to post
Share on other sites

Thats a good video, thank you! We had to add the capability to do successive trips later and it turned out surprisingly difficult! Lots of internal variables that need to be reset, and I think you may have found some of those.

Added to bug base!

I guess a workaround would be a reboot or reloading the aircraft before the second trip, but I think it should work ok without doing that.

Thanks, Jan

 

Edited by Litjan

Share this post


Link to post
Share on other sites
1 minute ago, Litjan said:

Thats a good video, thank you! We had to add the capability to do successive trips later and it turned out surprisingly difficult! Lots of internal variables that need to be reset, and I think you may have found some of those.

Added to bug base!

Thanks, Jan

 

LuaGC is apart of gizmo I see.  My frame rates seem to be a lot higher than usual.  Is there a way to turn this off?  I just don't need another application trying to alter x plane.  I dunno.  Is there a way to reset it so LuaGC isn't doing anything?  

Share this post


Link to post
Share on other sites
2 minutes ago, Litjan said:

Thats a good video, thank you! We had to add the capability to do successive trips later and it turned out surprisingly difficult! Lots of internal variables that need to be reset, and I think you may have found some of those.

Added to bug base!

Thanks, Jan

 

Well with VNAV off, its obviously very possible.  I think all these bugs are coming from the VNAV.  Mainly its descent planning.  

Share this post


Link to post
Share on other sites
1 minute ago, d0rkiishchris said:

LuaGC is apart of gizmo I see.  My frame rates seem to be a lot higher than usual.  Is there a way to turn this off?  I just don't need another application trying to alter x plane.  I dunno.  Is there a way to reset it so LuaGC isn't doing anything?  

I have no idea, I am not a programmer. As far as I understand, the Lua Garbage Collector running is a necessity. Ben has added a way to tweak the values for that in the Gizmo preferences, so you can go for either short, frequent, or longer, infrequent burst of GC activity.

Cheers, Jan

 

Share this post


Link to post
Share on other sites
12 hours ago, d0rkiishchris said:

LuaGC is apart of gizmo I see.  My frame rates seem to be a lot higher than usual.  Is there a way to turn this off?  I just don't need another application trying to alter x plane.  I dunno.  Is there a way to reset it so LuaGC isn't doing anything?  

If you turn the GC off trash will accumulate until the Lua memory pool is exhausted and the plugin crashes.

You cannot disable it as it wouldn't achieve anything useful if you could.

 

If your frrame rates are "a lot higher than usual" while using this product I'm not sure why you believe this is an issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×