Jump to content
Cameron

Take Command! IXEG 737 Classic v1.21 Update Released!

Recommended Posts

22 minutes ago, clif737 said:

Sorry - didnt wait long enough possibly

You can check the remaining alignment time if you set the switch to STS (time in minutes)

Jan

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Sounds like you need more beta testers who are more representative of the community, and run multiple plugins.  Of course there's no way to identify every conflict, but a general issue like "a lot of plugins" would be easily caught.

Tim

NO beta test will ever prepare you for the many thousands of people who use the product once it's in the wild. The issues reported here are not affecting majority of customers.

We have a lot of beta testers between all products at X-Aviation. Each one of these people are regular customers like you.

Share this post


Link to post
Share on other sites

I was able to fly 1.21 today for the first time. I have to say it worked great. I have been flying other planes lately, and struggling with ground effect to be honest.... not with the 733 1.21. It was so good to spend some time with 733 again, congrats to the team! The flight model is so good, good performance and seems stable. Makes me smile!

 

  • Upvote 1

Share this post


Link to post
Share on other sites

I have stayed away from this aircraft until this update is available.  I think I’m going to purchase this but I have one question to whoever can answer. I hear some people complaining about losing FPS on this recent update. 

I just updated my computer to-

8700K @5.0 GHZ, 1080ti 32GB of RAM @3000MHZ

Will this run this aircraft without any issues?

kind regards 

Share this post


Link to post
Share on other sites

@Flying12

Hi, I have the same setup, but haven't OCd the CPU yet. Expect 60-70fps with all settings, except reflections at max on regular airport/cities. High 50s to low 60s in more congested areas. You should have no problem with the add-on what so ever. My feedback about FPS was that I used to have 75-85, but now have 65-75 which is an indication that something has changed that made things perform less than before in my case.

Cameron however summarised it perfectly in a previous post, that this is not the case for everybody. Most will probably experience an increase, but a subset of users, myself included, are experiencing a decrease. That being said, it looks like they're looking into it so I'm confident they'll sort it out. Remember that these guys where the first ones to provide us with a complex aircraft that actually ran better than many of the default aircraft back in X-plane 10. How they were able to do that, I have no idea, but they're pretty good at keeping this bird running buttery smooth and I suspect they will continue to do so in the future :)

Share this post


Link to post
Share on other sites

"the fps spikes are too big!"

"the fps is too low!"

 

I'll be providing an control panel to choose between "higher fps big spikes" OR "lower fps spikes but more consistent FPS" with a simple check box.

There's no free lunch here. The drop is the result of both more detailed graphics AND Gizmo being tuned for more consistent fps with less spiking.

  • Upvote 3

Share this post


Link to post
Share on other sites

Can you confirm that this update 1.21 is NOT suitable for XP10 as the flight dinamics are tunded for XP11.1?

If that's correct, can we expect a future version with al lthe improvements but comaptible in dinamics with XP10?

Thanks

Share this post


Link to post
Share on other sites
27 minutes ago, Yavapai said:

Can you confirm that this update 1.21 is NOT suitable for XP10 as the flight dinamics are tunded for XP11.1?

If that's correct, can we expect a future version with al lthe improvements but comaptible in dinamics with XP10?

Thanks

No, I can not confirm this.

The 1.21 update is suitable for both XP10 and XP11.1x+ . The installer contains different versions of the aircraft and will install the correct set for your simulator version.

Most improvements are for both XP10 and XP11 users, but some (like the adjustment for flight dynamics or the added cockpit reflections) are only valid for XP11.

So both groups of users benefit from 1.21.

Cheers, Jan

 

Share this post


Link to post
Share on other sites
7 minutes ago, Litjan said:

No, I can not confirm this.

The 1.21 update is suitable for both XP10 and XP11.1x+ . The installer contains different versions of the aircraft and will install the correct set for your simulator version.

Most improvements are for both XP10 and XP11 users, but some (like the adjustment for flight dynamics or the added cockpit reflections) are only valid for XP11.

So both groups of users benefit from 1.21.

Cheers, Jan

 

That sounds good!!

Thanks Jan, im gonna update then!

 

Share this post


Link to post
Share on other sites
On 2/9/2018 at 7:47 AM, Captain_Crow said:

Switched off all plugins except Gizmo before loading the 733, see at picture what happened...

 

Best

Steff

IXEG_2.jpg

I know you guys are looking into it, but, I'm also having this issue above. I did a clean Windows installation yesterday (installed new SSD) and the only plugins that I have installed except aircrafts (SSGE195, FFB767, FFA320) are SkyMaxx and RWC. Everything installed a clean copy, even X-Plane. Not restored any plugins, settings or sceneries yet.

If I go into Developer -> Reload Aircraft, the IXEG loads correctly.

However, it loads the IXEG with everything running... not cold and dark :-(

plugins.png

For me, sometimes I can't load IXEG correctly even after a fresh XP11 run. 

 

Edited by DeshMindER

Share this post


Link to post
Share on other sites
1 hour ago, DeshMindER said:

I know you guys are looking into it, but, I'm also having this issue above. I did a clean Windows installation yesterday (installed new SSD) and the only plugins that I have installed except aircrafts (SSGE195, FFB767, FFA320) are SkyMaxx and RWC. Everything installed a clean copy, even X-Plane. Not restored any plugins, settings or sceneries yet.

If I go into Developer -> Reload Aircraft, the IXEG loads correctly.

However, it loads the IXEG with everything running... not cold and dark :-(

plugins.png

For me, sometimes I can't load IXEG correctly even after a fresh XP11 run. 

 

Working on a fix for that as we speak (type) - just hold on for a little bit longer.

Jan

 

  • Upvote 1

Share this post


Link to post
Share on other sites
32 minutes ago, ROBBAN said:

Hi!

What is the recommended joystic settings in this update?

Thanks,

Robert

Same as before - 25% linearity, 0% artificial stability.

Jan

 

  • Upvote 1

Share this post


Link to post
Share on other sites
15 minutes ago, Litjan said:

Working on a fix for that as we speak (type) - just hold on for a little bit longer.

Jan

 

Oh Jan, I was just reporting it. I´m very patient, take as long as you need. No worries.

Thanks 

Share this post


Link to post
Share on other sites

I have to say these guys work very hard and make a good product. I know that in dev sometimes there are bumps. I was finally able to get going to do a complete flight. Thanks to IXEG and all you do Keep it up - its the most realistic plane so far.  

  • Upvote 1

Share this post


Link to post
Share on other sites
5 hours ago, marpilot said:

Seeing these problems I stay on v.1.2

It is working well now for me. Completed yet another flight perfectly. I switched to X-plane from FSX and have been pleased with it. I see multiple people always having to fiddle with P3d versioning and that just seems like a better FSX. I am glad that people like IXEG and others flying xplane continue to stay with it. This plane is phenomenal. The sounds, the controls - yes it doesn't have doors that open but none of my airports have gates that work. Love this plane - It is worth the cost and I believe as good if not better than pmdg. It is a plane being polished to a point where those on other platforms will be envious.  Flying routes - dealing with weather - this plane makes me smile. No regrets

  • Upvote 2

Share this post


Link to post
Share on other sites
21 hours ago, Tim013 said:

What are autopilot modules?

Datarefs were added to allow people to interface with the autopilot annunciators and various modes of automation when using the AP. Example, when you disconnect the A/T you get a flashing red indicator that when pushed, cancels the flashing red light.  Same with AP and also there is an amber FMC light.    Then when flying with AP on in the upper part of the EADI, you see what mode the AP is in, LNAV, HDG, VOR/LOC etc as well as the pitch modes like VNAV, VS, LVL CHG, etc.  Lastly you have the CRZ, CLB, CON, etc modes of AT.

There were also some added for Flight Director Bars and LNAV cross track but none of these are working at the moment and they are aware of it.   All this was done with sim builders in mind.

Rob       

Share this post


Link to post
Share on other sites
On 2/11/2018 at 5:02 PM, Litjan said:

Working on a fix for that as we speak (type) - just hold on for a little bit longer.

Jan

I can get it to work by disabling Gizmo via plugin manager, re-enabling it and then reloading the aircraft.

Share this post


Link to post
Share on other sites

To whoever may have the best advice.

like I stated in a earlier post I’m ready to purchase this aircraft after the recent update. Now I read about FPS spike problems and Gizmo( what the hell is it?) also I’m hearing about holding on we are working on a fix? 

The last thing I want to do is drop $75 for issues right from the start... is this aircraft going to work after a new purchase,download and install or not?

  • Downvote 1

Share this post


Link to post
Share on other sites

Thanks for this update. Does the FMC have no reflection effect on the screen? The STALL WARNING TEST does not work on NO.1 and NO.2. Thanks and I'm looking forward to the next update. Sorry about my English.

X-Plane Screenshot 2018.02.16 - 14.44.19.90.png

X-Plane Screenshot 2018.02.16 - 16.01.00.13.png

  • Upvote 1

Share this post


Link to post
Share on other sites
8 hours ago, Flying12 said:

To whoever may have the best advice.

like I stated in a earlier post I’m ready to purchase this aircraft after the recent update. Now I read about FPS spike problems and Gizmo( what the hell is it?) also I’m hearing about holding on we are working on a fix? 

The last thing I want to do is drop $75 for issues right from the start... is this aircraft going to work after a new purchase,download and install or not?

Holdings dont work. If they are important to you, I would stay away.

Cheers, Jan

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×