Jump to content
korkiley

Unable to login to the X-Aviation Licensing window

Recommended Posts

When I start the Avanti I get a login window for X-Aviation Licensing. When I enter my Customer E-mail and password for X-Aviation the login fails. The simulation still seems to work though. Since this is freeware I was surprised to get this license window. Is there some other place I need to register with an actual X-Aviation Licensing email and password?

I just discovered the Avanti on Susi Air Virtual and finally found this developer's rendition. I can't believe it is freeware. Both the aircraft and simulation are amazing. Great job and I'm looking forward to future upgrades that promise to make it even better!

Share this post


Link to post
Share on other sites
18 minutes ago, korkiley said:

When I start the Avanti I get a login window for X-Aviation Licensing. When I enter my Customer E-mail and password for X-Aviation the login fails. The simulation still seems to work though. Since this is freeware I was surprised to get this license window. Is there some other place I need to register with an actual X-Aviation Licensing email and password?

I just discovered the Avanti on Susi Air Virtual and finally found this developer's rendition. I can't believe it is freeware. Both the aircraft and simulation are amazing. Great job and I'm looking forward to future upgrades that promise to make it even better!

We came to an agreement to allow free use of the Gizmo scripting engine in exchange for a some exposure to the rest of the X-Aviation catalouge. :)

As for the error, despite a code review and cleanup, there still seem to be some complex passwords that will trip it up.

Please try changing your password via the X-A site and see if the new version works.

This annoys me greatly but I can't exactly go around asking people what their password is to discover the common fault that trips it.

Edited by Ben Russell

Share this post


Link to post
Share on other sites
1 hour ago, korkiley said:

When I start the Avanti I get a login window for X-Aviation Licensing. When I enter my Customer E-mail and password for X-Aviation the login fails. The simulation still seems to work though. Since this is freeware I was surprised to get this license window. Is there some other place I need to register with an actual X-Aviation Licensing email and password?

I just discovered the Avanti on Susi Air Virtual and finally found this developer's rendition. I can't believe it is freeware. Both the aircraft and simulation are amazing. Great job and I'm looking forward to future upgrades that promise to make it even better!

Just close the window and everything will work fine. Maybe it is a small annoyance, but I hope that the aircraft redeems that! And this is only the "initial" Gizmo-ed version. This version was just to wrap up to make the plane work, rather a complete one. A newer version is ready to be released in the next days, with many improvements. 

If you have any more question, feel free to use the dedicated support forum, here (check the upcoming updates too!):

 

Share this post


Link to post
Share on other sites
3 hours ago, Ben Russell said:

We came to an agreement to allow free use of the Gizmo scripting engine in exchange for a some exposure to the rest of the X-Aviation catalouge. :)

As for the error, despite a code review and cleanup, there still seem to be some complex passwords that will trip it up.

Please try changing your password via the X-A site and see if the new version works.

This annoys me greatly but I can't exactly go around asking people what their password is to discover the common fault that trips it.

Thank you Ben. I do tend to have long complex passwords including special symbols! I will try dumbing it down and see if that works.

Share this post


Link to post
Share on other sites
2 hours ago, airfighter said:

Just close the window and everything will work fine. Maybe it is a small annoyance, but I hope that the aircraft redeems that! And this is only the "initial" Gizmo-ed version. This version was just to wrap up to make the plane work, rather a complete one. A newer version is ready to be released in the next days, with many improvements. 

If you have any more question, feel free to use the dedicated support forum, here (check the upcoming updates too!):

 

Thank you Ilias! If you are only getting started with this product I am really, really looking forward to the update(s)! I'm making my first flight right now. Your introductory video was a great help. I manged to enter a flight plan in the FMS but failed to follow it and was unable to change my next waypoint so it keeps showing my last way point and the distance from same : ) If, sometime in the future you could do a video with more detail about the FMS, that would be wonderful.

Kor

Share this post


Link to post
Share on other sites
Thank you Ilias! If you are only getting started with this product I am really, really looking forward to the update(s)! I'm making my first flight right now. Your introductory video was a great help. I manged to enter a flight plan in the FMS but failed to follow it and was unable to change my next waypoint so it keeps showing my last way point and the distance from same : ) If, sometime in the future you could do a video with more detail about the FMS, that would be wonderful.

Kor

Thanks a lot for your kind words! Avanti is a child of love, that I enjoy to work with. But also serves a purpose too. Helps me to test things in an operational aircraft that I have full access, things that will be transfered to my payware projects, like the DC9.

Make sure that you have pressed the NAV REF button, until FMS appears in the displays. That makes FMS the active nav source, and the plane should follow the flight plan.

Share this post


Link to post
Share on other sites

I updated to Windows 10 1803 this morning and when I next opened X-Plane, the X-Aviation update licence window opened asking for my email address and password but would not allow any input.  When I opened the Gizmo plugin and attempted to change my preferences - same sort of thing - the preferences were all listed but there was no tick box and clicking on anything did nothing.  

What have I done to break this?

Share this post


Link to post
Share on other sites
3 minutes ago, MikeyT said:

I updated to Windows 10 1803 this morning and when I next opened X-Plane, the X-Aviation update licence window opened asking for my email address and password but would not allow any input.  When I opened the Gizmo plugin and attempted to change my preferences - same sort of thing - the preferences were all listed but there was no tick box and clicking on anything did nothing.  

What have I done to break this?

You're using an X-Plane beta. Laminar broke it. Only Laminar can fix it. They've been notified.

 

  • Upvote 1

Share this post


Link to post
Share on other sites
16 hours ago, Ben Russell said:

You're using an X-Plane beta. Laminar broke it. Only Laminar can fix it. They've been notified.

 

Thanks for the quick reply Ben.  Much appreciated!

Share this post


Link to post
Share on other sites

Hey Ben, 

I'm also having the same issue as MikeyT, but not on beta. Is it because I updated my Windows 10 to 1803? Please assist: this is super annoying! 

Regards,

Shelman 

Share this post


Link to post
Share on other sites
Hey Ben, 

I'm also having the same issue as MikeyT, but not on beta. Is it because I updated my Windows 10 to 1803? Please assist: this is super annoying! 

Regards,

Shelman 

Change your X-Plane UI zoom level back to 100%.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×