Jump to content
alpha12125

[XP11]soft crash during approach

Recommended Posts

i know xp11 is not supported, but i thought i might aswell post about it.

 

sadly i didnt take a screenshot because it was right before approach, but i will try to describe what happend. Tomorrow i will be able to try to reproduce it but maybe someone else can try it in the meantime.

here is the flight i did:

 

ROUTE STATUS:  active

Using version: 1.1
DEPA:        KSNA
ARRA:        KSFO
CRUISE:   36000
PERF:     Data is complete
SID:      HHERO1
SIDT:     IKAYE
START:    None
STAR:     SERFR2.28R
APPT:     None
APP:      ILS28R
DEP Rwy:  20R
ARR Rwy:  28R

 

During approach everything was working well, appart from the drag issue (but that is well known in xp11 :) ). The approach was programmed at flaps 30 /133kts.  SInce there was gusting winds of 35kts, i saw the option wind correction in the app menue  I tried to change the settings from 5kts to 10kts, which worked, but the calculated speeds didnt update. i thought maybe i need to press exec and thats when i got the soft crash. sadly it was in the middle of the approach so i couldnt take a screenshoot as the plane started to pitch down vigerously and needed my attention.

in the gizmolog i found the following lines that seemed to show what happend:

debug: 5412.316: TK: FMS speed is: 294.49582361262
debug: 5479.729: TK: EXEC pressed
error: 5479.744: Callback_Dref_Hooked_setDataf: cdu1_exec_OnWrite: [string "ixeg.733.draw_route.lua.ra1"]:4174: attempt to index a nil value

 

it happend right after i pressed exec, did someone else experience this aswell ?

 

Edited by Morten

Share this post


Link to post
Share on other sites

Hi,

I can confirm that this happens even in XP10 when you hit EXEC on the Approach Ref page... I just selected flaps 30 / 134KT and pressed EXEC. Gizmo soft crash.

Jean.

GizmoLog.txt

Edited by jfjoubert
Added xplane version

Share this post


Link to post
Share on other sites

...and just to ease you guys over until we fix this (havent been able to reproduce it yet), this is the correct procedure:

Enter the combo of landing flap setting/Vref into the dashed lines field at LSK4R. You can click on the precalculated values to copy them to the scratchpad, or enter them yourselves.

Then set the MCP speed cursor to the target speed (calculate it according to the flight manual). The "wind corr" value I never messed with and I think it may have something to do with the plane flying approaches on VNAV with FMC calculated speeds...

Jan

 

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×