Jump to content
Sign in to follow this  
edc1

Saab 340 Engines not starting

Recommended Posts

Hi, I recently purchased the les Saab 340 and had done a few flights with it; however, recently I have not been able to start the engines. When I put the condition lever to start and feather and switch the ignition the engine sounds like its spooling up, but the temp only rises to about 30 and the rpm increases slightly. The same thing happens with the auto start feature. Has anyone had this problem that can help? 

Share this post


Link to post
Share on other sites
2 hours ago, mmerelles said:

if you are running xp11 beta 12 engines may not start, this beta is broken. otherwise please provide more details for help

Yeah, that's what I'm running. Hopefully they'll fix this in the next beta or final release.

Share this post


Link to post
Share on other sites

The Saab is not compatible with XP11 yet.  

Once XP11 goes out of beta, we'll start working on an update to make the Saab compatible.

Edited by Goran_M

Share this post


Link to post
Share on other sites
On 26-2-2017 at 9:44 PM, Goran_M said:

The Saab is not compatible with XP11 yet.  

Once XP11 goes out of beta, we'll start working on an update to make the Saab compatible.

This is great news, i am enjoying it so far on xplane 11, (most stuff is working).. but officially compatible would be amazing!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×