Jump to content
sthenion

[FAQ]Solution to freeze and stutter using FMC

Recommended Posts

Unbelievable aircraft in quality and realism! A New bar has been set for every flight sim platform. I don't track framerates, but I look for smoothness, with virtually no stutters. I have a capable system. I have all of the latest heavies and with resolution on high and other settings fairly low, I get virtually linear/smooth flight with all of them, including the MD80. However, I am getting a micro stutter every few seconds with the 737 in the air and moving on the runway. I tried every setting possible to relieve the issue but no matter what resolution I use I still get a micro stutter every few seconds. Its tolerable because of the level of quality of this plane, but I'm very picky about any stutters, so I'm concerned that this aircraft may just be too much for my system? Any more optimization to come?

Edited by Morten

Share this post


Link to post
Share on other sites

I also have micro stutters, especially when taxiing on ground, less noticeable in the air, but what is weird is that fps remain stable and high.

Share this post


Link to post
Share on other sites

I too get the micro stutters - not huge issue but does impact the immersion factor a touch.

Love  the plane guys, a real joy to fly and the textures are beautiful :). This is everything I had hoped.  I will be patient as the bugs are worked out. 

Edited by Whiskey Rebel

Share this post


Link to post
Share on other sites

Interesting...maybe this is not an issue with my system but possibly a bug that can be fixed? To me it's strange that it's happening on the ground? In the air it happens everywhere, near airports, over water etc. It doesn't seem to be caused by heavy scenery areas.

Share this post


Link to post
Share on other sites

i am noticing this as well. When on the ground, evertime i move the throttles up and back down it happenes. When in the air ( I have FPS counter on... example...it fluctuates from 70 and drops to low 60's, high 50's, then back to 70 every two seconds.  Actually depends what area I'm in as far as the higher fps is concerned. 

 

Best, Jeff

Share this post


Link to post
Share on other sites

Thanks for the reports, everyone.

You can output the FPS in a graphical representation, using the "Settings" and "Data input & output" menus. Then check the third box from the left near field 0 frame rate. Now let the sim run for a bit, then go back and go to the DATA SEE tab. Here you can see a representation of your FPS over time.

There are a lot of calculations set up to run "every two seconds" and you can see that in the representation, like a negative "heartbeat". I will add this "problem" to our bug database, it isn´t really a bug but more of a coding limitation. Just maybe we can try to even the load out a bit more.

Jan

 

Share this post


Link to post
Share on other sites

Thank you Jan. It helps to understand what is happening. I'm not sure how to interpret my data, but here is my screenshot. I am running with the refresh rate of monitor selected.

1461507747591-832347232.jpg

Share this post


Link to post
Share on other sites

There have been some more reports on stutters. Here are some tips:

  • disable other plugins (and reboot X-plane) temporarily to test if they affect this
  • disable windows defender (or add an exclusion to the X-Plane folder)
  • make sure you don´t fly with a MOD route - it recalculates the route every two seconds (until you EXECute), this is a heavy load on the CPU

Let me know how it goes, Jan

 

Share this post


Link to post
Share on other sites

Hi Jan

I just tested your suggestions and unfortunately I still get a short stutter/pause about every 3 seconds from the time I start down the runway for takeoff and during flight. I am so hoping that this can be solved. This aircraft is just too incredible to have parked in the hangar if I don't have the juice to run it smoothly. By the way, I definitely don't have a powerhouse pc, but its been quite capable so far. Here are my specs....

XFX 780i motherboard, Intel Q9650 3ghz OC'D to 4ghz, 8gb ram, Geforce GTX 760 2gb

Thanks for your efforts and responses!

Share this post


Link to post
Share on other sites

Here is my data output..

Standing on ground EDNY at flight preparation..

 

All plugins off except Skymaxx 3.1.1, Pilotview with TrackIR and FSGRW wit RWC..

 

Best

 

Steff

737_Data.jpg

Edited by Captain_Crow

Share this post


Link to post
Share on other sites

Try to disable ALL plugins, reload X-Plane and let me know?

The "heartbeat" framerate graph is normal - we do some calcs every two seconds... might spread that out more later.

Jan

 

Share this post


Link to post
Share on other sites

Thanks for reply !!

 

The rythm of your code reading or what ever seems to fitt the stutters, just a guess..

 

It´s 0018 lcl time here yet, I will give it a try with all plugins switched of in about 10 hrs or so...

 

Good night all...

 

Steff

 

Share this post


Link to post
Share on other sites

Hi guys,

 

me again with some new shots:

First: Plugin Folder empty, Gizmoz resetted afterwards

Second: Data ouput, still the same as with plugins.

Third: GPU load test window, seems okay

My system is: Win 7 Pro, SP1, Intel Core i7 CPU X 990@3.47Ghz, 24,0GB RAM, NVidia GeForce GTX 970

Hope this helps a bit to find the reason for the stutter...

Best

Steff

 

Plugin_Folder.jpg

737_Data_2.jpg

GPU.jpg

Edited by Captain_Crow

Share this post


Link to post
Share on other sites
14 hours ago, Litjan said:

Try to disable ALL plugins, reload X-Plane and let me know?

The "heartbeat" framerate graph is normal - we do some calcs every two seconds... might spread that out more later.

Jan

 

Hi Jan,

i tried what you said. No difference if flying with other plugins or without other plugins. The Plane and simulation itself runs very good (30 to 50 fps on my i7-2700 with 4BG GTX770 and 32GB-Ram) but these calculation-related "stutters" are for me not just visual. It seems like some of the GIZMO-Code runs in background while the sim stopps. In these microstutters the sound changes for me. All the stutters are going along with a volume change up (or additionally played wind/gust or somewhat sounds).

So the stutter itself is so short i might even not noticed it if it wouldn't be so loud...

I'll try to capture a video of the soundstutters...

And maybe related to that: if the sim makes a little break itself (like flying into a tile with very complex scenery) gizmo itself looks like it is trying to fly the plane while X-Plane tries to catch up all the new scenery data. So this rare moments where X-Plane needs much to load and the fps are going down to 2-6 fps (only for seconds) are the only moments when the AP seems to overreact (ie. pulling heavily up) or the throttle handles are going completely around the block and the sound is going up also (like with heavy turbulences)...like if gizmo and X-Plane are going out of sync. But after this short bad loading fps the plane catches up agan and the throttle handles are going to the right place again and the AP is going smooth back to normal flight...

But this are very rare moments.

Philip

Edited by Ubbi

Share this post


Link to post
Share on other sites

Ok... here you go: These Stutters are there for me every time (but not every 2 seconds! More like every 30 seconds to 2 minutes)

In this Video i was going from cold and dark as fast as i could. The first audible stutter is while/after turning the first IRS. The second stutter (a more loud one) was after engaging the window heat while changing view back down. I cut the middle of this video so it stays very short and little in size.

Philip

Soundstutters.mp4

Share this post


Link to post
Share on other sites

Try to add a exclusion for X-Plane in your Anti Virus software and see if that helps.
If you're just sporting Windows Defender, you can add exclusions for folders / exe files there too!

Share this post


Link to post
Share on other sites

I do have an exclusion inside my avira for the complete x-plane folder.

Next time i'll try with complete deactivated guard...

Share this post


Link to post
Share on other sites

Hi Philip,

fortunately I get these weird sound "cracks" on my laptop as well - so there is a chance we will track them down. Working on it!

Jan

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites

I'll be working closely with Tom and the team to optimise things like this.

I might have to add "Worker Threads" to Gizmo64 so we can do the heavy lifting stuff outside of the game loop.

Thanks for your patience while we figure it out... First we'll get it working, then we'll get it working faster. :)

Optimisation is definitely at the top of my list over the near future.

  • Upvote 3

Share this post


Link to post
Share on other sites

Could it be a Sound Card / Driver Issue?

I remember, back when Fallout 3 was released, on my old PC I had a dedicated Sound Card installed and the whole game had crazy stutters. After some hours of trying I switched to the onboard sound and suddenly I had a perfectly running Fallout 3.

Just an idea.

 

Share this post


Link to post
Share on other sites

Everything is worth a try... I have the issue (although its really minute) on my beefy laptop, but not on my (slightly less capable) desktop. So it´s not purely a matter of raw computing power...

Jan

 

Share this post


Link to post
Share on other sites

Ok. I can try it with my onboard-soundcard. But if this is working this should only be a workaround. I am flying with a PC i do also use for audio-mixing-recording as a Studio. I do have ProTools installed and all Sounds are played via a USB-connected M-AUDIO Ultra interface playing on nice ADAM-Audio Studiomonitors.

So if i switch to the onboard sound i can only use headphones (because the Adam's need XLR-Cables to connect).

And (to be honest) this would be a shame because: I LOVE your great sound you did with this Plane played through my Studiomonitors!!!

But do the important things first. This little cracks are not nice but also no dealbreaker.

Thanks for your great service!

EDIT : deaktivated and unplugged all my soundcards. Rebooting PC and flying now with onboardsound: no difference. This would also be strange if this would change anything. The audible stutters are (in my uneducated guess) resulting in the audioengine playing sounds while the sim itself have a little hiccup...

 

 

Edited by Ubbi

Share this post


Link to post
Share on other sites

What I have to tell is, thats really good how he conversation here runs !!  Great to read all the kind stuff here.

And to make it clear: I for myself agree fully with Ubbi: Its not a joybreaker it just disturbs a bit, and I am sure the IXEG guys will find and fix. I am very patient and a bit proud that I could support this project with my purchase.

Thanks again..

Steff

Quote

 

 

Share this post


Link to post
Share on other sites
57 minutes ago, Ubbi said:

Ok. I can try it with my onboard-soundcard. But if this is working this should only be a workaround. I am flying with a PC i do also use for audio-mixing-recording as a Studio. I do have ProTools installed and all Sounds are played via a USB-connected M-AUDIO Ultra interface playing on nice ADAM-Audio Studiomonitors.

So if i switch to the onboard sound i can only use headphones (because the Adam's need XLR-Cables to connect).

And (to be honest) this would be a shame because: I LOVE your great sound you did with this Plane played through my Studiomonitors!!!

But do the important things first. This little cracks are not nice but also no dealbreaker.

Thanks for your great service!

EDIT : deaktivated and unplugged all my soundcards. Rebooting PC and flying now with onboardsound: no difference. This would also be strange if this would change anything. The audible stutters are (in my uneducated guess) resulting in the audioengine playing sounds while the sim itself have a little hiccup...

 

 

 

Thank you for the data point. It's very useful. More an investigative request, definitely a temp work around.

Seamless sound is very important to us.

 

Thanks everyone for the support!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×