TedK

Live Weather Updates

22 posts in this topic

I installed the latest updates for Skymaxx Pro and Weather Connector with the NOAA server updates. When I grab real weather from the web, the new METAR data goes into the Weather Connector or Skymaxx Pro WX folder (can't recall exact file name, I'm not at the Sim computer) but not into the X-plane WX folder. I can cut & paste from one folder to the other and then click "Read Weather" on the X-Plane weather page and the current conditions will appear in the Sim. Under the plug-in drop down list, I have 'update real weather automatically, regardless of what is selected in X-plane weather page'. And I still have Grab Real Weather from the Web selected on X-Plane weather page, too. But no automatic live weather updates so far. It's getting into one WX folder but not the other. Any ideas?

1

Share this post


Link to post
Share on other sites

I'm confused about what you're seeing; if you could post some more specifics when you're at your computer it would be helpful.

There is no "WX" folder. X-Plane downloads METAR.rwx into the directory you installed X-Plane into, alongside the X-Plane application. If you set Real Weather Connnector to "always", then it downloads MAXX_METAR.rwx into that same directory. And that's where Real Weather Connector looks for those files. Perhaps you're seeing METAR data that's being downloaded by some other add-on?

What you might be missing is the X-Plane 10.50rc3 update, which fixes X-Plane's own download of METAR data.

Edited by sundog
1

Share this post


Link to post
Share on other sites

After clicking the weather download button on the X-Plane weather page, the METAR.rwx folder is empty or contains old data. The MAXX_METAR.rwx folder has the current data. I will look for the X-Plane 10.50rc3 update. That sounds like the fix I am missing. I hadn't seen anything about that prior to your post. Thanks for the feedback. Cheers :)

1

Share this post


Link to post
Share on other sites

I have 10.50r3 installed and smp and rwc all seems to be working using always and the Maxx metar is getting the info. The other metar is getting nothing even in automatic and error in downloadable weather still.

METAR.rwx

MAXX_METAR.rwx

Log.txt

Edited by jujub
0

Share this post


Link to post
Share on other sites
17 hours ago, jujub said:

I have 10.50r3 installed and smp and rwc all seems to be working using always and the Maxx metar is getting the info. The other metar is getting nothing even in automatic and error in downloadable weather still.

METAR.rwx

MAXX_METAR.rwx

Log.txt

I don't see any indication in your log that X-Plane even tried to download METAR data of its own. You can try to force it by going to X-Plane's weather screen, setting it into real weather mode, and click the "download now" button.

0

Share this post


Link to post
Share on other sites

Correct I did not try and would not show on the log but look at the metar.rwx file date in the contents. When I did click the download now I got error will try again in 59 minutes so I was never getting a download to the metar.rwx but your MAXX Metar.rwx was receiving the correct weather and was working for both smp and rwc.

 

0

Share this post


Link to post
Share on other sites
4 hours ago, jujub said:

Correct I did not try and would not show on the log but look at the metar.rwx file date in the contents. When I did click the download now I got error will try again in 59 minutes so I was never getting a download to the metar.rwx but your MAXX Metar.rwx was receiving the correct weather and was working for both smp and rwc.

 

That's weird. Even though this isn't a SMP/RWC issue, I'm curious as to what's going on there. If you could capture your log.txt after encountering a failed METAR download I'd like to see it; there should be some information in there pointing to the issue.

0

Share this post


Link to post
Share on other sites

That would not happen because I was running on Maxx Metar.rwx since March 7-2016 as that was the last update downloaded on the x-plane Metar.rwx on my machine and never had any problems on 10.45 except for the one crash operating on Maxx.rwx. Never thought on ever checking my Metar.rwx.

0

Share this post


Link to post
Share on other sites

Sounds like the cloud backdrop issue to me. Nudging your cloud draw area setting probably would have cleared it up.

I'll see if we can expedite the release of the fix for this somehow.

 

0

Share this post


Link to post
Share on other sites

Hi,

When looking at the provided metar files by jujub, we can see there are 4 or 5 cloud layers depicted for cyvr. This means lots of clouds ! And more than the 3 layers that are normally managed by x-plane.

How does SMP deals with the 2 more layers ? Are they displayed ?

 

Some time ago I did a post on this forum about a similar FPS issue... on cyvr too...

 

@sundog : have you tested the provided Metars (from jujub) on your test system ? 

I would be interested to kown if you can reproduce the issue and if yes, the fix you mention solves this...

Thanks.

 

edit : my original post about this same issue (see this post and next ones)

 

Edited by gcharrie
0

Share this post


Link to post
Share on other sites

I updated to XP-10.50rc3 and the live weather data download issues seems to be resolved. Getting the correct, current temps and altimeter settings now. However I occasionally still see abrupt changes in clouds while moving through different weather areas. I thought this was something SMP and WC smoothed out.

Edited by TedK
0

Share this post


Link to post
Share on other sites
2 hours ago, gcharrie said:

How does SMP deals with the 2 more layers ? Are they displayed ?

If you also have Real Weather Connector installed and active, yes the additional layers will also be displayed.

0

Share this post


Link to post
Share on other sites
2 hours ago, TedK said:

I updated to XP-10.50rc3 and the live weather data download issues seems to be resolved. Getting the correct, current temps and altimeter settings now. However I occasionally still see abrupt changes in clouds while moving through different weather areas. I thought this was something SMP and WC smoothed out.

If the "never change visible weather" option is on in Real Weather Connector, then you shouldn't see any weather changes as you fly as long as RWC is on.

If you are seeing changes, I'd question whether RWC is actually active. Try setting it to "always" mode to be sure, and double check that Skymaxx Pro indicates version 3.3 in its configuration screen.

 

 

0

Share this post


Link to post
Share on other sites

What impact on SMP AND RWC does having two metar reports to deal with. The reason I ask is my Metar report was redundant since March and never had fps problem once .Now updating three days now and get crash. Coincicidence?.

0

Share this post


Link to post
Share on other sites

SMP/RWC only reads one of the METAR file at a time. It uses X-Plane's METAR.rwx file if RWC is set to "automatic" mode, and our MAXX_METAR.rwx file only if RWC is set to "always" mode.

What probably happened is that the weather you just downloaded resulted in enough additional clouds compared to the weather you previously had as to cause a problem. 

I noticed you have custom scenery installed for CYVR, which may play a role in what you're experiencing. But I suspect you're really seeing the effects of a rare bug that we're in the process of patching. For now, you can just slightly change your cloud area setting in SMP if performance seems to tank for no apparent reason to fix it. Or, setting the cloud area below 10,000 should avoid the issue entirely until we issue a patch.

 

1

Share this post


Link to post
Share on other sites

After updating to the latest SMP and RWC, I noticed my weather stays the same, e.g. at KJFK, it is always wind 03003KT, altimeter 2992 everyday all the time. What could be the problem? I set "grab real weather from net" in x-plane and "automatic" in RWC and am still using x-plane 10.45. Is this still the NOAA weather server issue?

0

Share this post


Link to post
Share on other sites

I also have a similar or the same problem as jujub. In the middle of flight cruising at FL360, FPS suddenly dropped to 4-5 fps. I checked HW monitor, GPU usage is around 11%( it usually is around 90%), cpu usage is 25% (usually it is around 100%). Looks like the low fps is the result of not fully utilizing my hardware capabilities.

0

Share this post


Link to post
Share on other sites

If you are using the Rolon CRJ, that's a huge frame rate eater and has been known to bleed memory. The frame rates evetually come to a complete stop. Had to hanger mine. Waste of 50 bucks.

 

0

Share this post


Link to post
Share on other sites
On 9/4/2016 at 2:44 PM, TedK said:

If you are using the Rolon CRJ, that's a huge frame rate eater and has been known to bleed memory. The frame rates evetually come to a complete stop. Had to hanger mine. Waste of 50 bucks.

 

No I was not flying Rolon CRJ. It was EADT x737.

0

Share this post


Link to post
Share on other sites
After updating to the latest SMP and RWC, I noticed my weather stays the same, e.g. at KJFK, it is always wind 03003KT, altimeter 2992 everyday all the time. What could be the problem? I set "grab real weather from net" in x-plane and "automatic" in RWC and am still using x-plane 10.45. Is this still the NOAA weather server issue?

If you are using RWC in automatic mode with 10.45 then yes, that's not our issue and you'll need to upgrade to 10.5.

1

Share this post


Link to post
Share on other sites

Glad to report using SMP3.3.1 and RWC set to always Flying from CYQQ to CYVR In heavy clouds all the way not one problem with FPS hit low 27 and around 34 all the way into CYVR. Not like last week.

MAXX_METAR.rwx

METAR.rwx

1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.